A downloadable tool

Buy Now$5.00 USD or more

This plugin is also part of the Wave 5 Bundle!

You can also acquire this plugin through the All Waves Bundle!


When striking enemies with elemental attacks, it's difficult for the player to know at first glance if he or she has hit a weakness or resistance, especially if they are unfamiliar with how much damage the enemy should take normally. This plugin creates popups that appear upon being hit at various elemental rates, from 200% to 101% for Weaknesses, 99% to 1% for resistance, 0% for immunity, and under that for absorption.

Critical hits also gain an extra popup effect to indicate landing a critical hit in case they've missed the extra flash that comes with one by default. This plugin helps relay information to the player in a more visible form.

Features include all (but not limited to) the following:

  • Create popups that appear in battle whenever battlers take elemental damage that results in weaknesses, resistances, immunities, or absorption.
  • Critical hits will also generate popups.
  • Popups can use images or generate bitmap text on the spot.
  • Move the popups through various means like scaling and acceleration.
  • Elemental rates can generate different popups depending on the rate.

More information can be found here:

http://www.yanfly.moe/wiki/Weakness_Popups_VisuStella_MZ

✼Frequently Asked Questions

-

Q: If I buy this plugin, do I keep it forever?

A: Yes. If you bought this plugin directly, go to your "My Library" link tied to your itch.io account by clicking on your profile in the upper right corner of the screen. If you bought an Access Key associated with this plugin, then you can just simply download it directly from the page.

-

Q: If a plugin gets updated after I purchase the plugin, will I be able to download it again without repurchasing the plugin?

A: Yes. If you bought this plugin directly, go to your "My Library" link tied to your itch.io account by clicking on your profile in the upper right corner of the screen. If you bought an Access Key associated with this plugin, then you can just simply download it directly from the page.

-

Q: How do I install the plugin into my RPG Maker MZ project?

A: You can install the plugin by following these steps found here.

-

Q: How do I update the plugin if I already had it installed in my RPG Maker MZ project?

A: You can update the plugin by following these steps found here.

-

Q: I've found a bug with this plugin. Where do I report it?

A: Please report it with the link from the Troubleshooting Guide found here.

-

Q: Does this plugin have _____ feature?

A: Be sure to look at the documentation that we have linked on this page to see if it does. If it's not listed there, it does not have the specified feature.

-

Q: Is this plugin compatible with _____ ?

A: VisuStella MZ Tier 0 through 4 plugins should be compatible with each other. We cannot give certainty for Tier 5 plugins as they are made as a one-of compatibility patch. Compatibility with plugins outside of the VisuStella MZ library are also harder to judge so we cannot give any clear answers for that.

-

Q: What are the Terms of Use for this plugin?

A: They can be found on their documentation in either the wiki link or within the plugin itself.

-

Updated 5 days ago
Published 12 days ago
StatusReleased
CategoryTool
AuthorVisuStellaMZ
GenreRole Playing
Tagsmz, plugins, RPG Maker, rpgmakermz, rpg-maker-mz, rpgmakerz-mz, tools

Purchase

Buy Now$5.00 USD or more

In order to download this tool you must purchase it at or above the minimum price of $5 USD. You will get access to the following files:

Weakness Popups plugin (v1.00) 45 kB
PopupAbsorb.png 38 kB
PopupCriticalHit.png 19 kB
PopupImmune.png 27 kB
PopupResist.png 26 kB
PopupWeakness.png 24 kB